UberStudent Forums
http://uberstudent.com/phpBB/

Snow while watching videos in Chrome but not in Firefox
http://uberstudent.com/phpBB/viewtopic.php?f=9&t=380
Page 1 of 2

Author:  Jason Wallwork [ Tue Jan 22, 2013 12:17 pm ]
Post subject:  Snow while watching videos in Chrome but not in Firefox

Hi there!

I've been a longtime user of Linux but have been using Windows Vista and 7 more since the former came out. Still kept in touch with Linux trying it out in virtual machines and older hardware.

Anyway, I really love the look of this distro and love that Chrome is included. However, I seem to have an issue playing video, at least from youtube.com. The audio is fine and it streams okay, but there's "greenish-yellow snow flecks" over the screen and dance about during the playing of the video. I don't see this problem in Firefox. I tried using the stable version of Chrome thinking that it might be a bug in the beta but it does the same thing.

I'm using integrated Intel video. I could probably try and find the exact kind of it if that info is needed but I don't have it handy.

Attached a screenshot of the region showing the "snow".

Attachments:
SnowOnVideosm.png
SnowOnVideosm.png [ 239.29 KiB | Viewed 21603 times ]

Author:  Jason Wallwork [ Tue Jan 22, 2013 12:25 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Forgot to add that I'm using the Desktop version of UberStudent, 2.04.1, I think...

Just released I might have downloaded an older version although I get it's not that much older judging by the date. I'm not sure if there is a way to check this. I actually didn't realize how new this distro is. I actually discovered UberStudent while using LinuxLive USB Creator and looking through their list to see which ones it would download and seeing it and wondering what it was.

Btw, I'm also founder and president of a LUG in Peterborough, Ontario, Canada. And it's freaking cold up here!

Author:  David Baum [ Tue Jan 22, 2013 5:25 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Hi Jason,

the difference between Firefox and Google Chrome is that Firefox by default uses the HTML5 technology to stream youtube videos (at least it does in my version, I think: Lightweight Edition released a couple of days ago. But I'm not sure because even if I turn HTML5 off in Firefox, I'm still able to play most of the videos :? ) while Google Chrome has a flash plugin integrated by default in the browser in order to play them. So the source of your problem might come from the flash plugin.
Try installing the chromium browser and the separate flash plugin package and see if that makes a difference. Chromium is basically the same as Google Chrome.
Code:
apt-get install chromium-browser chromium-codecs-ffmpeg chromium-codecs-ffmpeg-extra flashplugin-installer

BTW my flash player version in Google Chrome is 11.5.31.137 and everything works fine. What is yours, please?

David

Author:  Stephen Ewen [ Tue Jan 22, 2013 7:45 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

That video is looking okay on my end.

Image

I'm using the latest Chrome that will update via the repository.

You might try just running
Code:
sudo apt-get upgrade
and see if there's an update for the Chrome version you're running.

NOTE: Installing Chromium and removing Chrome will break all of the webapps in UberStudent. However, there's a 2-second fix I can give you if you decide to do that.

By that particular video, I'm guessing you're doing some very serious research into human psychology or something. :lol: :mrgreen:

Author:  David Baum [ Tue Jan 22, 2013 8:05 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Quote:
NOTE: Installing Chromium and removing Chrome will break all of the webapps in UberStudent

Thanks for bringing this up before Jason followed my advice :shock:

The video plays fine for me too. Google Chrome Version 25.0.1364.36 beta

Author:  Stephen Ewen [ Tue Jan 22, 2013 8:15 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

In the case of removing Chrome and installing Chromium, the 2-second fix for all the webapps is to simply create a symlink pointing to Chromium.

Run this in a terminal:

Code:
sudo ln -s /usr/bin/chromium /usr/bin/google-chrome


Done. Now all your webapps will use Chromium.

One more thing: Zotero is not known to work well with Chromium. That's why UberStudent has Chrome over Chromium in the first place.

Author:  Jason Wallwork [ Tue Jan 22, 2013 8:52 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

David Baum wrote:
Hi Jason,
BTW my flash player version in Google Chrome is 11.5.31.137 and everything works fine. What is yours, please?


I checked at Adobe's website and the version is 11,2,202,261. I'll see if there is an update I can get for this via the update manager.

Author:  Jason Wallwork [ Tue Jan 22, 2013 8:57 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Stephen Ewen wrote:

By that particular video, I'm guessing you're doing some very serious research into human psychology or something. :lol: :mrgreen:


Lol. The funny thing is that I don't even drink. There was another video before that that was funny and I just clicked on a random video on the related screen at the end just to make sure it wasn't a specific video codec or something that was causing problems :D

I'm willing to break things to try and fix things as I haven't really customized the desktop much. So I can just re-install if need be. I forgot that Flash is included in Chrome. I'm a big Chrome fan, so you'd think I'd remember that. I guess I thought maybe it was different under Linux. So I'm going to try Chromium and the flash plugin and see how it goes.

Author:  Jason Wallwork [ Tue Jan 22, 2013 9:13 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Jason Wallwork wrote:
David Baum wrote:
Hi Jason,
BTW my flash player version in Google Chrome is 11.5.31.137 and everything works fine. What is yours, please?


I checked at Adobe's website and the version is 11,2,202,261. I'll see if there is an update I can get for this via the update manager.


Oops. I had that wrong. I gave you the version for Firefox. In Chrome, it's 11,5,31,137, same as yours.

Author:  Jason Wallwork [ Tue Jan 22, 2013 9:41 pm ]
Post subject:  Re: Snow while watching videos in Chrome but not in Firefox

Just removed Chrome and installed Chromium with the ffmpg codecs extra. I used synaptic to do it and noticed that flashplayer was already installed, with firefox, I assume. Tried a youtube video and it works perfectly!

Makes me wonder if it's because it's a newer version of Flash or just a newer modified verson of Flash that Google Chrome uses that is the problem. But it's clearly something related to the flash included with Chrome.

I also noticed that Synaptic seems to allow you install Chromium alongside Chrome. I didn't actually follow through with because you guys said to remove it. However, when I tried adding it without removing it, in the list of changed packages, it didn't list removing Chrome. So if I end up using Zotera, I can probably install Chrome just for it.

I did the symlink too.

Thanks, guys!

Page 1 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/