UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Fri Jun 22, 2018 2:34 pm

All times are UTC




UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Wed Jul 30, 2014 9:25 pm 
Offline
New UberStudent User

Joined: Wed Jul 30, 2014 9:17 pm
Posts: 3
I have recently installed UberStudent 4.0 x64 and it was working just fine. After a recent restart, however, Update Manager says it cannot refresh the list of packages. I tried Synaptic, but it doesn't work either and gives the same error message:

E: The value 'socrates' is invalid for APT::Default-Release as such a release is not available in the sources
E: _cache->open() failed, please report.


Everything else seems to function normally. I am new to Linux, please help.


Top
 Profile  
 
Click Here to Get Inexpensive UberStudent Discs

Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!
PostPosted: Fri Aug 01, 2014 5:34 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
This bug was due to a race situation between apt and synaptic; usually apt was winning, which is why you've not seen the issue consistently. The fix was trivial and is now included in the package uberstudent-xfce-default-settings-enduser. Just run the Update Manager from the top-right normal updates panel and the fix will be applied.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Fri Aug 01, 2014 9:37 pm 
Offline
New UberStudent User

Joined: Wed Jul 30, 2014 9:17 pm
Posts: 3
Thanks for a prompt response, Stephen!

Everything is working normally again, though I did have to run sudo apt-get update and sudo apt-get upgrade in the terminal first, as the Update Manager remained stuck until I did so. (Perhaps I should have tried that before my initial post?) Anyway, as soon as I did that, UM was able to refresh again and found the package you mentioned. Thanks for fixing the repeated icon issue, as well.


Top
 Profile  
 
PostPosted: Sat Aug 02, 2014 8:30 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
The Update Manager runs the apt-get update command very early in its routine. In basic terms, the command simply reads the current state of the repositories, creates lists based upon that state, and makes the state available for further reading.

apt-get upgrade reads the output of apt-get update and simply installs all newer versions of packages, including some (e.g., the Linux kernel and xorg) that the Upgrade Manager actually blacklists because such updates can potentially reduce system stability. UberStudent users should always prefer the Update Manager, and not the command line or any other method, when doing updates, unless they have some specific reason to do otherwise.

If you have any future issues with updating, please do simply reboot as your first step. The most common update issues are checked for and, if they exist, silently fixed in UberStudent whenever you reboot.

FYI, I normally fix reported bugs that I can replicate within 24 hours, usually less, often much less. I appreciate it very much when users report issues to me so I can fix them.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Mon Aug 04, 2014 10:39 pm 
Offline
New UberStudent User

Joined: Wed Jul 30, 2014 9:17 pm
Posts: 3
Rebooting was my initial response to the bug when it surfaced; though since you hadn't yet fixed it, no surprise it didn't do anything. Noted about trying a reboot first after the fix has been issued, thanks. :geek:


Top
 Profile  
 
PostPosted: Thu Sep 11, 2014 12:49 am 
Offline
New UberStudent User

Joined: Wed Sep 10, 2014 9:23 pm
Posts: 1
Hi Stephen,

Great package for a 69 yoy Pensioner. Thanks

I just installed but cannot Update or install new packages.

Following message:
++ Launching uberstudentUpdate in root mode
++ Starting refresh
++ Auto-refresh timer is going to sleep for 15 minutes, 0 hours and 0 days
-- Error in checkAPT.py, could not refresh the list of packages
++ Install requested by user

Otherwise package works excellent.

Have tried to update via Terminal but this did not work/reset!

Cheers,

Ton


Top
 Profile  
 
PostPosted: Thu Sep 11, 2014 1:43 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
The repository was down for a short while today. You can just log out and log back in, and then run the update manager again and it work as expected. :geek:

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Sun Sep 21, 2014 3:33 pm 
Offline
New UberStudent User

Joined: Sun Sep 21, 2014 3:17 pm
Posts: 1
Hello !

I'm having the same problem also !!!! Know the reason and how can I solve ?????

Already hung up, tried in various ways to update the update manger, but this always reports the same type of error !!!

ERROR###ERROR###ERROR###ERROR###ERROR###ERROR###ERROR
E:The value 'socrates' is invalid for APT::Default-Release as such a release is not available in the sources

Antonio R. Silva


Top
 Profile  
 
PostPosted: Sun Sep 21, 2014 4:15 pm 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
Did you read this thread before posting?

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Mon Sep 22, 2014 12:30 pm 
Offline
UberStudent Forum Helper

Joined: Fri Jul 25, 2014 11:17 pm
Posts: 65
I am in the process of installing US 4.0 for at least the forth time now, and I have encountered this problem (at least almost every time, if not) every time.

There is something wrong with the auto-updater.

It does not work on a new US 4.0 installation until sudo apt-get update has been run manually, then it works. Until sudo apt-get update was run, it returns the error that antonior_silva has reported above.

Once the auto-updater has run once, it seems to be OK henceforth.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ]  Go to page 1, 2  Next

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!



All times are UTC


Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group