UberStudent Forums
http://uberstudent.com/phpBB/

Uberstudent appinstaller error
http://uberstudent.com/phpBB/viewtopic.php?f=5&t=1098
Page 1 of 1

Author:  Lucio [ Sun Jan 03, 2016 9:00 am ]
Post subject:  Uberstudent appinstaller error

"Error divide by zero" when I try to install Extra Education Apps.
I'm running Uberstudent 4.3 on Virtualbox (linuxmint)

Attachments:
error.log [472 Bytes]
Downloaded 560 times

Author:  Stephen Ewen [ Sun Jan 03, 2016 1:47 pm ]
Post subject:  Re: Uberstudent appinstaller error

I just now did the following in UberStudent 4.3 64-bit:

- Ensured I was connected to the Internet
- Ran Extra Education Apps from the Applications > Education menu
- Selected Kompozer and installed it

There were no errors and everything went as expected. Since I cannot replicate the issue by taking the above steps, can you please explain in more detail exactly what you did that led to the error?

Author:  Lucio [ Sun Jan 03, 2016 2:43 pm ]
Post subject:  Re: Uberstudent appinstaller error

I've tried now to install composer. You can see what happens (video file opened with firefox):

https://drive.google.com/file/d/0B17Zd0 ... sp=sharing

I must restart, then composer is installed.

(P.S.: why geogebra isn't between educations apps?)

Author:  Stephen Ewen [ Mon Jan 04, 2016 1:06 am ]
Post subject:  Re: Uberstudent appinstaller error

Are you using UberStudent 32-bit or 64-bit?

Are you saying that after the error, the installation still succeeds?

Please go to Applications menu > System > Administration > Fixes and run Software System Fixer. Then try again. If you still get the error, open a terminal (hit F12 on your keyboard) and run
Code:
apt-install kompozer
and let me know the result.

Author:  Lucio [ Mon Jan 04, 2016 6:09 am ]
Post subject:  Re: Uberstudent appinstaller error

I've installed Uberstudent 4.3 xfce amd64
yes, after the error the new software is ok, it works before running Software System Fixer (look at the stamp).
Then I've ran Software System Fixer.
Then I run "apt-install kompozer" and the answer is: "kompozer is already the newest version".
Then I've installed "control aula" and then "coccinella" and error again (twice)
Coccinella works without reboot

Attachments:
control alula.png
control alula.png [ 137.75 KiB | Viewed 20230 times ]
Uberstudent error2.png
Uberstudent error2.png [ 423.32 KiB | Viewed 20230 times ]
File comment: kompozer is ok after reboot (no need fx or reinstall)
Uberstudent [In esecuzione] - Oracle VM VirtualBox_004.jpg
Uberstudent [In esecuzione] - Oracle VM VirtualBox_004.jpg [ 48.84 KiB | Viewed 20230 times ]

Author:  Stephen Ewen [ Mon Jan 04, 2016 2:13 pm ]
Post subject:  Re: Uberstudent appinstaller error

Well, as you can see, I am having no issue with the appinstaller:

https://drive.google.com/file/d/0BxD4TDWbKv_BYkNSZGxWTUFMb0E/view?usp=sharing

Since I cannot replicate the issue, I cannot debug anything. Further, the error you are getting is apparently trivial, since installation proceeds as normal.

Author:  Lucio [ Mon Jan 04, 2016 2:46 pm ]
Post subject:  Re: Uberstudent appinstaller error

Perhaps it is because I have installed on the virtual machine. The trouble is that I have to reboot to close the window that reports the error.
I thought that the log files could be helpful. However, if it's okay to you, it's good enough for me.. :)

Author:  Stephen Ewen [ Mon Jan 04, 2016 10:54 pm ]
Post subject:  Re: Uberstudent appinstaller error

Yes, I can replicate the error when running the appinstaller inside virtualbox.
Attachment:
0-error.png
0-error.png [ 48.98 KiB | Viewed 20205 times ]
It is not an appinstaller error but a Nouveau or virtualbox driver error:
Attachment:
x.png
x.png [ 35.52 KiB | Viewed 20205 times ]
More than likely, you can avoid the error (and others) by going to Applications menu > System > Software > Driver Manager and running it and installing whatever driver it recommends to you.

Author:  Lucio [ Tue Jan 05, 2016 7:41 am ]
Post subject:  Re: Uberstudent appinstaller error

Than you so much :)
all's well that ends well :D

(but I run "driver manager", updating cache, it says "No proprietary driver in use" and that's all: no recommendations :cry: )
virtualbox in use: 5.02

Author:  Stephen Ewen [ Tue Jan 05, 2016 8:23 am ]
Post subject:  Re: Uberstudent appinstaller error

Yes, that may be the case in Virtualbox. If you install UberStudent to your harddrive, that will not be the case. This issue appears to happen only in Virtualbox. There's nothing I myself can do about it, since it does not involve UberStudent code, and tinkering with drivers is a specialty I do not know.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/