UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Sun Jan 21, 2018 8:46 pm

All times are UTC




UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Sun Jan 03, 2016 9:00 am 
Offline
New UberStudent User

Joined: Sun Jan 03, 2016 8:48 am
Posts: 5
"Error divide by zero" when I try to install Extra Education Apps.
I'm running Uberstudent 4.3 on Virtualbox (linuxmint)


Attachments:
error.log [472 Bytes]
Downloaded 343 times
Top
 Profile  
 
Click Here to Get Inexpensive UberStudent Discs

Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!
PostPosted: Sun Jan 03, 2016 1:47 pm 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 954
Location: UberStudent Headquarters
I just now did the following in UberStudent 4.3 64-bit:

- Ensured I was connected to the Internet
- Ran Extra Education Apps from the Applications > Education menu
- Selected Kompozer and installed it

There were no errors and everything went as expected. Since I cannot replicate the issue by taking the above steps, can you please explain in more detail exactly what you did that led to the error?

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Sun Jan 03, 2016 2:43 pm 
Offline
New UberStudent User

Joined: Sun Jan 03, 2016 8:48 am
Posts: 5
I've tried now to install composer. You can see what happens (video file opened with firefox):

https://drive.google.com/file/d/0B17Zd0 ... sp=sharing

I must restart, then composer is installed.

(P.S.: why geogebra isn't between educations apps?)


Top
 Profile  
 
PostPosted: Mon Jan 04, 2016 1:06 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 954
Location: UberStudent Headquarters
Are you using UberStudent 32-bit or 64-bit?

Are you saying that after the error, the installation still succeeds?

Please go to Applications menu > System > Administration > Fixes and run Software System Fixer. Then try again. If you still get the error, open a terminal (hit F12 on your keyboard) and run
Code:
apt-install kompozer
and let me know the result.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Mon Jan 04, 2016 6:09 am 
Offline
New UberStudent User

Joined: Sun Jan 03, 2016 8:48 am
Posts: 5
I've installed Uberstudent 4.3 xfce amd64
yes, after the error the new software is ok, it works before running Software System Fixer (look at the stamp).
Then I've ran Software System Fixer.
Then I run "apt-install kompozer" and the answer is: "kompozer is already the newest version".
Then I've installed "control aula" and then "coccinella" and error again (twice)
Coccinella works without reboot


Attachments:
control alula.png
control alula.png [ 137.75 KiB | Viewed 13086 times ]
Uberstudent error2.png
Uberstudent error2.png [ 423.32 KiB | Viewed 13086 times ]
File comment: kompozer is ok after reboot (no need fx or reinstall)
Uberstudent [In esecuzione] - Oracle VM VirtualBox_004.jpg
Uberstudent [In esecuzione] - Oracle VM VirtualBox_004.jpg [ 48.84 KiB | Viewed 13086 times ]
Top
 Profile  
 
PostPosted: Mon Jan 04, 2016 2:13 pm 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 954
Location: UberStudent Headquarters
Well, as you can see, I am having no issue with the appinstaller:

https://drive.google.com/file/d/0BxD4TDWbKv_BYkNSZGxWTUFMb0E/view?usp=sharing

Since I cannot replicate the issue, I cannot debug anything. Further, the error you are getting is apparently trivial, since installation proceeds as normal.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Mon Jan 04, 2016 2:46 pm 
Offline
New UberStudent User

Joined: Sun Jan 03, 2016 8:48 am
Posts: 5
Perhaps it is because I have installed on the virtual machine. The trouble is that I have to reboot to close the window that reports the error.
I thought that the log files could be helpful. However, if it's okay to you, it's good enough for me.. :)


Top
 Profile  
 
PostPosted: Mon Jan 04, 2016 10:54 pm 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 954
Location: UberStudent Headquarters
Yes, I can replicate the error when running the appinstaller inside virtualbox.
Attachment:
0-error.png
0-error.png [ 48.98 KiB | Viewed 13061 times ]
It is not an appinstaller error but a Nouveau or virtualbox driver error:
Attachment:
x.png
x.png [ 35.52 KiB | Viewed 13061 times ]
More than likely, you can avoid the error (and others) by going to Applications menu > System > Software > Driver Manager and running it and installing whatever driver it recommends to you.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
PostPosted: Tue Jan 05, 2016 7:41 am 
Offline
New UberStudent User

Joined: Sun Jan 03, 2016 8:48 am
Posts: 5
Than you so much :)
all's well that ends well :D

(but I run "driver manager", updating cache, it says "No proprietary driver in use" and that's all: no recommendations :cry: )
virtualbox in use: 5.02


Top
 Profile  
 
PostPosted: Tue Jan 05, 2016 8:23 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 954
Location: UberStudent Headquarters
Yes, that may be the case in Virtualbox. If you install UberStudent to your harddrive, that will not be the case. This issue appears to happen only in Virtualbox. There's nothing I myself can do about it, since it does not involve UberStudent code, and tinkering with drivers is a specialty I do not know.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!



All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group