UberStudent Forums

Help and Community for Users of Uberstudent
Return to UberStudent Home Page
It is currently Thu Jul 19, 2018 9:20 am

All times are UTC




UberStudent Logo Shirt
Hey! You can wear this UberCool UberStudent Logo Shirt

Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Musescore behaviour
PostPosted: Tue Nov 24, 2015 6:48 pm 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
I installed via ppa and terminal Musescore.It works even if I haven't test it yet properly.
During installation I read on terminal Musescore was disinstalling Audacious , so it has been.
Now Two Questions:
a) Why?
b) may I reinstall Audacious without spoiling Musescore?


Top
 Profile  
 
Click Here to Get Inexpensive UberStudent Discs

Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!
 Post subject: Re: MuseScore Behaviour
PostPosted: Wed Nov 25, 2015 9:56 am 
Offline
UberStudent Staff
User avatar

Joined: Mon Jan 21, 2013 7:18 pm
Posts: 110
Enrico Contenti wrote:
I read on terminal Musescore was disinstalling Audacious

This post on the MuseScore.org forums addresses a conflict between MuseScore and Audacious. (Uninstalling Audacious without prompting the user seems like an inappropriate resolution on the part of the MuseScore developers.) One user reported that he was able to resolve the conflict by also installing gawk. If you opt to reinstall Audacious you will probably also have to install gawk to resolve the conflict, though I suggest that you inquire on the MuseScore.org forums first before any further action.

_________________
Cybermancy.net - Creativity via code


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Wed Nov 25, 2015 3:25 pm 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
gawk was already installed in Uber when I setup Musescore


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Thu Nov 26, 2015 5:58 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
Does audacious work?

Since the debian control file for musescore does not contain a conflicts declaration with audacious, and the post-installation script contains nothing to that end, what you probably actually saw getting was audacious-omg-- just a script and declared LADSPA dependencies that places some OMG! :shock: sound settings into Audacious--getting uninstalled. It depends on multiple plugins that may conflict with dependencies required for musescore. It's no problem to uninstall audacious-omg. If it complains about uninstalling uberstudent-desktop-xfce, that's no problem either since it's just a metapackage (a package that contains a list of packages to install, created for my own convenience when building UberStudent. I'm travelleing right now and on a borrowed laptop, so can't look in to this further just right now.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Thu Nov 26, 2015 8:02 pm 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
This what I was answered in Musescore forum:
Posted by shoogle on November 26, 2015 - 2:21am new
Answer to (b):
It's possible that only part of Audacious has been removed and that the program is still there and working just fine (see below), if not then go ahead and reinstall. Try uninstalling and then reinstalling both programs if necessary. Remember to save your work first.
Answer to (a):
Many programs for Ubuntu actually consist of multiple packages. There are 15 different packages with Audacious in the title, any of which might be the one you saw was uninstalled. These might be separate packages for the GUI, terminal, underlying engine/backend, icons, multimedia, plugins, developer tools, optional features, special integration with other apps, and of course packages of any other programs or software libraries that the main program relies on. The advantage of the separate packages is that sometimes programs can share a package. For example, Audacious and MuseScore are both audio programs so it is not unlikely that they share some audio libraries, in which case you would only need the more recent version of the library. If that is the case then Audacious should still be installed, but now it will be using MuseScore's version of the library instead of its own.


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Thu Nov 26, 2015 8:07 pm 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
audacious-omg is not installed on Uberstudent!


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Thu Nov 26, 2015 9:47 pm 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
Enrico Contenti wrote:
audacious-omg is not installed on Uberstudent!
Then you uninstalled it in some way. No worries, it's just an optional nice addition in UberStudent, something I made myself several years ago. I promise it's OMG! amazing, if you want to reinstall it, though. ;-)

I just added this musescore stable PPA and went to install it. Nothing audacious or audacious-related conflicts.
Attachment:
noa-omg.png
noa-omg.png [ 113.71 KiB | Viewed 11174 times ]
What happens when you try to run audacious? If audacious runs, you have no problem at all. Did you mean audacity? You may have installed it. That being removed while installing musescore would make much more sense, actually.

Did you install a PPA that installed some other version of Audacious? If so, we really need to work with you on how to report actual UberStudent issues. Supporting UberStudent users who add PPAs will-nilly is not something we or anyone else can reasonably support, when the problem you are having is NOT with UberStudent but with specific programs you installed via PPA, which by definition are NOT TRUSTED sources of software. As the article I linked to above states, if you NEED some program not in the normal Ubuntu or UberStudent repositories, ask here and let me evaluate the stability and feasibility of adding the program to the uberstudsent.net respository. DO NOT just add a PPA, unless you really know what you are doing AND/OR are prepared to turn your system into a "latest release software testing system," AND are able to handle it yourself. No Linux distro can support the entirety of all variables in the free software world, just like Microsoft cannot support the entirety of all variables in the non-free software world. UberStudent supports UberStudent and the UberStudent packages and programs installed by default, not however and whatever are the myriad and sundry ways you are using the tools of Linux to transform your system into, essentially, Enrico OS.

In summary, if there is some new version of an upstream program you think you really need to get your actual work done and it is not already available in any official Ubuntu or UberStudent repository, there may be an exceptionally good reason as to why--Ubuntu developers, as well as UberStudent and other upstream developers, are constantly testing new releases of software and adding them to their official repositories without anyone asking, and they add the new versions whenever they are stable and it makes good sense to do so. Please do not just install the PPA of some program's newest release and ask upstream developers, such as myself, to pick up the pieces if things break. They very often will. Instead, post here, telling me you need a new version of the particular software and why, and let me myself evaluate the program for official inclusion into the official UberStudent repository. In that way, we can ensure a stable system for all. Linux is not Windows. There is a safe and smart hierarchy to it for very good reason. Let me help you! On the other hand, it's your Linux. You can make it anything you want...such as Enrico OS. Just don't expect me to support that just like I do UberStudent OS. ;-)

And in the future, whenever you think you have a problem with a program, run its name in a terminal, e.g., audacious. Doing so will normally tell you of any issue, if there really is one.

At this point, I don't think there really is any actual issue with audacious and musescore working alongside each other, so I'm tentatively closing this thread. Let me know if otherwise....

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Fri Nov 27, 2015 4:00 pm 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
To Stephen.

I can't run audaciuos anymore becouse it's not in the menu .
Anyway I don't want to create my own distro and I am sorry if my post has created bad humour in you.
As I play guitar I just wanted to study some music with Musescore. That's all!

When I say that I read on terminal audaciuos was disinstalling getting Musescore and then I didn't find it in the menu (using Application finder too)or going to Multimedia folder, everything is true.
I post all that to you to let you know what did happen to me when I installed Musescore.You are still studying Linux I think, you made your own distro and I thought it would be interesting to you knowing what happened to me.
As Uberstudent , your distro, is devoted to students I can't see any Music App for those who study it or are lovers of the subject.


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Sat Nov 28, 2015 6:07 am 
Offline
UberStudent Founder and Lead Developer
User avatar

Joined: Sun Nov 11, 2012 8:54 am
Posts: 956
Location: UberStudent Headquarters
A supported version of musescore is easily installable right within UberStudent by going to Applications menu > Education > Subjects > Extra Subjects Apps. My point it that if you install anything via PPA, things are not always going to go as smoothly than if you were to install a version that is supported from the repositories already contained in UberStudent; and, that if a program you need is out of date and a new version has new features you need, it's much preferable for the sake of keeping a fully working system to ask me here to add the new version of the program in to the UberStudent repository. That way I can test it myself and, if need be, package it myself, and ensure that everything runs nice and smooth for you, the user. Adding PPAs to a system is frequently a destabilizing action, because the packages in them just aren't neccessarily tested. I'm just trying to help you keep a smoothly running system! Here are some guidelines on PPAs you might consider toward that end. :geek:

Now to the issue at hand:

Please open a terminal and run:
Code:
audacious
Please post the output here.

Next, please open a terminal and run:
Code:
apt-cache policy audacious
Please post the output here.

Then, please open a terminal and run:
Code:
sudo apt-get install audacious
Please post the output here.

_________________
UberStudent Must Become Self-Sustaining. If UberStudent and my dedicated support of it has benefited you, it's important to make a donation. Thanks!

The UberStudent Headquarters:
    * Mobo: MSI 870-G45
    * Processor: AMD Phenom II X4 3.4GHz
    * RAM: G.SKILL 8GB DDR3 1600
    * Graphics: MSI NVIDIA GeForce GTX 750 Ti
    * Drive: OCZ Vertex SSD
    * Case: Rosewill ATX Mid Tower
    * Monitors: 2 x Dell UltraSharp
    * With UberStudent 4.3 Development Build
You should build your own computers, too!


Top
 Profile  
 
 Post subject: Re: Musescore behaviour
PostPosted: Sun Nov 29, 2015 10:10 am 
Offline
UberStudent Forum Helper

Joined: Fri Oct 11, 2013 5:26 pm
Posts: 55
Here it is what you asked:


1) enrico@enrico-Aspire-T180:~$ audacious
The program 'audacious' is currently not installed. You can install it by typing:
sudo apt-get install audacious

2) enrico@enrico-Aspire-T180:~$ apt-cache policy audacious
audacious:
Installed: (none)
Candidate: 3.7-1~webupd8~trusty0
Version table:
3.7-1~webupd8~trusty0 0
600 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/ trusty/main i386 Packages
100 /var/lib/dpkg/status
3.4.3-1 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages


3) enrico@enrico-Aspire-T180:~$ sudo apt-get install audacious
[sudo] password for enrico:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
audacious : Depends: audacious-plugins (>= 3.7) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

enrico@enrico-Aspire-T180:~$
thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

Click Here to Get Inexpensive UberStudent Discs


Click here to get UberStudent discs delivered to your mailbox
Delivered Directly to Your Mailbox!



All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group