UberStudent Forums
http://uberstudent.com/phpBB/

system cleaner hosed my system
http://uberstudent.com/phpBB/viewtopic.php?f=4&t=925
Page 1 of 1

Author:  DontTazeMe [ Sat Feb 28, 2015 7:45 pm ]
Post subject:  system cleaner hosed my system

I ran system cleaner and accepted the first y/n and skipped the second, and not sure what I chose after that, then installed a bunch of electronics software from synaptic. When I rebooted it froze with the diamond shaped uber logo on screen. I tried recovery boot option and used dpkg, then it froze at the samba line during boot. I'm working from my xp partition now. I'd rather not reinstall because I spent a lot of time tweaking this and that and have to rescue my bookmarks and files etc.

If you would like to look at it I can set up some kind of remote access (vnc?) from my xp partition and I seem to recall an ext driver for windows. I think I'm running ext3 format on my uber boot partition.

Any advice is appreciated.

Author:  Stephen Ewen [ Sat Feb 28, 2015 8:12 pm ]
Post subject:  Re: system cleaner hosed my system

What happens when, during the boot menu, you choose advanced options and boot from there? What are the options in your advanced boot menu?

Author:  DontTazeMe [ Sat Feb 28, 2015 11:48 pm ]
Post subject:  Re: system cleaner hosed my system

Thanks
There is a "recovery" menu item which I guess is what you meant by "advanced"

r resume normal boot
clean
dpkg check - tried it
fsck
grub update
enable networking
root shell
summary

Author:  Stephen Ewen [ Sun Mar 01, 2015 1:33 am ]
Post subject:  Re: system cleaner hosed my system

No, I meant Advanced, but there may not be that option, which tells me info.

Print this to paper and take the steps:

1. Boot in to the Recovery mode and at the prompt select the option for network and select Yes to remount the filesystem. This will run a few things and then return you to the recovery prompt.
2. At the recovery prompt choose the option for root and login in with your password
3. Run the following lines:
Code:
sudo apt-get update
sudo apt-get install linux-kernel-generic
sudo reboot

Success?

Author:  DontTazeMe [ Sun Mar 01, 2015 2:58 am ]
Post subject:  Re: system cleaner hosed my system

This is embarrassing. Its been so long since I logged in as root that I forgot the password. I thought it was the same as my user account which works when I do sudo from my user account. But when I tried it for root it didn't work.

Help us Obi Wan, you're our only hope.

Author:  Obi-Wan Kenobi [ Sun Mar 01, 2015 5:19 am ]
Post subject:  Re: system cleaner hosed my system

;)

I've sensed a disturbance in the Force.

Unless you specifically set the root password to something other than the password you use with sudo, it should be the same.

Did you type correctly?

But assuming you set a specific root password...there is no good reason to do that. Doing so only introduces a disturbance in the Force. So we must bring balance back to it.

Please print what follows to a parchment scroll, or have your Droid memorize the lines, and then take the steps.

1. At the grub menu press "e" on your keyboard. This will open up a dialog where you can change the boot perimeters.

2. Scroll through the text to near the bottom to the line that begins with linux. You will see a long string of numbers and letters, something like root=UUID=4rc4b7rbx47r-776fv77b7-c44-8886gt5 followed by ro quiet splash $vt_handoff.

3. Replace ro quiet splash with rw init=/bin/bash such that it looks like root=UUID=4rc4b7rbx47r-776fv77b7-c44-8886gt5 rw init=/bin/bash $vt_handoff

Before:
Code:
root=UUID=4rc4b7rbx47r-776fv77b7-c44-8886gt5 ro    quiet splash $vt_handoff

After:
Code:
root=UUID=4rc4b7rbx47r-776fv77b7-c44-8886gt5 rw init=/bin/bash $vt_handoff

Leave what comes before root=UUID alone.

4. After you get that inputted correctly, hit F10 on your keyboard. You will now boot in to a wondrous, passwordless, root shell, set in place by the ancients. Feel their presence with you.

5. Now reset your password by typing passwd root and then set your new root password.

6. Now type reboot

7. Now take the steps above you printed earlier.

If that fails to re-balance the Force, then the Darkside has overtaken you. You'll need to re-install the system. Before doing that you can boot in to the UberStudent Live Disk, open a file manager and mount the drive where your installation is located, and move any files you want to retain to an external drive. To keep your bookmarks, for example, you can copy over the entire folder at /home/yourusername/.config/chromium and then copy that folder back to your new installation before you run Chromium and after you run all system and program updates.

May the Force be with you. :lol: :mrgreen:

Author:  DontTazeMe [ Wed Mar 04, 2015 9:26 am ]
Post subject:  Re: system cleaner hosed my system

Obi Wan you are one with the force. The login trick worked. Unfortunately order has not been restored.
My one remaining question is, is there a way to get a list of all the packages I had installed?

Author:  Obi-Wan Kenobi [ Wed Mar 04, 2015 12:48 pm ]
Post subject:  Re: system cleaner hosed my system

Did you also take the steps in point #7, above?

You cannot get a list of installed packages unless you can boot in to the system from which you desire to obtain the list of installed packages.

May the Force be with you.

Author:  sarwanov [ Tue Apr 28, 2015 6:52 am ]
Post subject:  Re: system cleaner hosed my system

That's good post you shared.well done

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/