UberStudent Forums
http://uberstudent.com/phpBB/

[FIXED] Failed to fetch chrome repo error on upgrade
http://uberstudent.com/phpBB/viewtopic.php?f=4&t=1151
Page 1 of 1

Author:  chthonicanimus [ Wed Mar 02, 2016 7:08 pm ]
Post subject:  [FIXED] Failed to fetch chrome repo error on upgrade

[ Admin note: this thread and its posts have been truncated to make everything brief for other users who come along needing the same fix ]

I decided to install UberStudent on a newer laptop because I was having so many issues on the older one. I used the UberStudent 4.1 disc I ordered from your site. It installed fine, but when it prompted me to update to 4.3 there started being glitches. It wont update properly and I get error messages.
Code:
Could not download all repository indexes

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.


Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)
Some index files failed to download. They have been ignored, or old ones used instead.

Author:  Stephen Ewen [ Thu Mar 03, 2016 5:12 am ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

Thank you for reporting this issue. Shortly after you reported it, I also got the same error.

The issue is now fixed.

Explanation:

Google dropped support for Chrome in Linux 32-bit machines. Therefore, when apt checked the Google Chrome repository, it gave the error because the main/binary-i386/Packages file no longer exists. Apparently, Google did its planned removal just several hours ago.

I have updated the package uberstudentsources and placed it into the uberstudent.net repository. It fixes the issue by either forcing a 64-bit machine to check the Google Chrome repository for amd-64 packages only, or if your machine is 32-bit by removing the Google Chrome repository altogether and also giving the user a warning prompt about Google dropping support for 32-bit Google Chrome.

How to get the fix:

If your Update Manager is in a state of error (red shield, error text), just open it and click the Refresh button. The new version of uberstudentsources will display as available. Install it and the issue will be fixed. Alternately, you may open a terminal and run this line:
Code:
sudo apt-get update && sudo apt-get install uberstudentsources
If for some reason things are being stubborn, download the new package directly, right-click it, and install it with Gdebi.

Author:  chthonicanimus [ Thu Mar 03, 2016 4:16 pm ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

Tried all three different options you listed. I keep getting an error message that says I have unmet dependencies.Wont let me fix the broken package in synaptic. Unsure how to proceed.

Author:  Stephen Ewen [ Thu Mar 03, 2016 4:38 pm ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

Not sure what may have gone wrong, since these fixes are working for me. Run Software System Fixer from the System > Software menu. Let me know if that works. If it does not, I'd like to remote in to your system, if you don't mind. I'll private message you in that case.

Author:  chthonicanimus [ Fri Mar 04, 2016 8:12 pm ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

When I run the commands in the terminal I get this message:

uberstudentsources is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
uberstudent-xfce-default-settings-enduser : Depends: uberstudent-xfce-default-settings-helper (>= 1.6.2) but 0.0.3.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

and when I try what it suggests I get:

turtle@turtle-HP-Pavilion-dm4-Notebook-PC:~$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

So I try to add sudo since it may have been missing:

turtle@turtle-HP-Pavilion-dm4-Notebook-PC:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
uberstudent-xfce-default-settings-helper
The following packages will be upgraded:
uberstudent-xfce-default-settings-helper
1 upgraded, 0 newly installed, 0 to remove and 119 not upgraded.
29 not fully installed or removed.
Need to get 0 B/422 kB of archives.
After this operation, 2‚ÄČ821 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: dependency problems prevent configuration of uberstudent-panel-changer:
uberstudent-panel-changer depends on uberstudent-xfce-default-settings-enduser; however:
Package uberstudent-xfce-default-settings-enduser is not configured yet.

Author:  Stephen Ewen [ Sat Mar 05, 2016 6:22 am ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

Attachment:
Screenshot_2016-03-05_00-24-26.png
Screenshot_2016-03-05_00-24-26.png [ 48.65 KiB | Viewed 11452 times ]
You don't have all of the updates installed. Your system does not have the heraclitus repository in it. Run this in a terminal and the issue should go away:
Code:
sudo apt-get install uberstudentsources
I'm not sure what happened, because that is the package that triggers the entire upgrade from 4.1 to 4.3.

Author:  chthonicanimus [ Sat Mar 05, 2016 9:53 pm ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

Ran that command:

turtle@turtle-HP-Pavilion-dm4-Notebook-PC:~$ sudo apt-get install uberstudentsources
[sudo] password for turtle:
Reading package lists... Done
Building dependency tree
Reading state information... Done
uberstudentsources is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
uberstudent-xfce-default-settings-enduser : Depends: uberstudent-xfce-default-settings-helper (>= 1.6.2) but 0.0.3.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Author:  Tom L Johns [ Fri Apr 08, 2016 7:28 pm ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

I was having the same issue, and could not get a resolution following the tips in this thread so far. On advice from an Ubuntu site I was able to get "repairs" done by using
Code:
sudo aptitude -f install


However that only said it fixed the issue, but upon a reboot, the issue persisted.

What I came across was that my LibreOffice evidently had some conflict issue. Again, using aptitude because apt-get would not work, I removed LibreOffice. Rebooted. And I had to trigger an upgrade (though I read you should not do a command line upgrade). Then everything worked for me. I have made it to 4.3.

Author:  Stephen Ewen [ Sat Apr 09, 2016 7:07 am ]
Post subject:  Re: [FIXED] Failed to fetch chrome repo error on upgrade

This should be fixed in the repo now.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/